Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 01, 2026 - 11:00 CDT
Scheduled
What’s Happening:
We are deploying Firmware v88 as part of the staged rollout of this access control upgrade. The update includes minor bugfixes and improvements. Deployment for each phase will occur over a rolling 72-hour window.
Minnesota and FAC clubs are not included in this maintenance window, as they have already received the upgrade.
When: All Remaining Domestic Begins: June 01, 2026 at 11:00 AM CT Rolling Window: 72 hours from start time
Impact: Devices may update at different times within the 72-hour window. No extended downtime is expected. Clubs can continue operating normally throughout the maintenance period.
What You Need to Do: No action is required. Devices will update automatically. Our teams will monitor performance and device health throughout each 72-hour deployment window.
If issues persist after the update please report them through your standard support channel.
Posted Jun 01, 2026 - 09:58 CDT
This scheduled maintenance affects: Technology (Door Service).