Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 16, 2026 - 11:00 CST
Scheduled
What’s Happening:
We are deploying Firmware v83 as part of the staged rollout of this access control upgrade. The upgrade brings necessary updates to support Samsung Wallet features and enhances system stability. Deployment for each phase will occur over a rolling 72-hour window.
When: -Minnesota Clubs And FAC Begins: February 16, 2026 at 11:00 AM CT -Rolling Window: 72 hours from start time
All Remaining Domestic and International Clubs -Begins: February 23, 2026 at 11:00 AM CT -Rolling Window: 72 hours from start time
Impact: -Devices may update at different times within the 72-hour window. -No extended downtime is expected. -Clubs can continue operating normally throughout the maintenance period.
What You Need to Do: -No action is required. Devices will update automatically. Our teams will monitor performance and device health throughout each 72-hour deployment window.
If issues persist after the update, please report them through your standard support channel.
Posted Feb 13, 2026 - 11:40 CST
This scheduled maintenance affects: Technology (Door Service).