ABC - OBC Invoice Display
Incident Report for Anytime Fitness
Resolved
ABC reports that this issue has now been resolved.

Please submit any further issues to ABC support.
Posted Nov 11, 2024 - 17:36 CST
Identified
ABC has informed us that they are currently aware of an issue with the Online Business Center where member invoices will not display.
At this time, owners can call client services to update member accounts at 888-622-6290.

An update will be provided when ABC has resolved this issue.
Posted Nov 11, 2024 - 13:59 CST
This incident affected: Partners (ABC Fitness Solutions).