Incident: Personal Training Sign-Ups Impacted (Club OS & ABC Integration)

Incident Report for Anytime Fitness

Resolved

The issue preventing clubs from adding new payment profiles and initiating Personal Training sign-ups in Club OS has been resolved.

If you previously encountered an error, please re-attempt the action.
Posted Dec 16, 2025 - 14:45 CST

Investigating

We are currently experiencing an issue affecting the ABC payment integration within Club OS, which is preventing clubs from initiating Personal Training (PT) sign-ups when adding a new profile payment method for members.

Impact:
Clubs may be unable to complete Personal Training agreements
The issue occurs when attempting to add a new payment profile
Existing payment profiles may continue to function normally

Affected users may see the following error message: “Unable to initialize pay page with ABC.”
Posted Dec 16, 2025 - 10:02 CST
This incident affected: Partners (ABC Fitness Solutions, Club OS).