Lead Capture Degradation

Incident Report for Anytime Fitness

Identified

We are in recovery mode and actively addressing the influx of bad leads. Cleanup is in progress, and a fix is being developed to prevent further occurrences.
Posted Mar 31, 2025 - 18:55 CDT

Investigating

We are currently experiencing degraded performance in our Lead Capture services resulting in false leads.

Our team is actively investigating the issue and working to restore full functionality as quickly as possible. We are closely monitoring the situation and will share updates as they become available.
Posted Mar 28, 2025 - 15:40 CDT
This incident affects: Technology (Online Signup).