ABC has confirmed that the delayed deposit files from Wednesday and Thursday are now processing and being sent. Affected clubs should see the delayed funds reflected in their accounts by Monday, August 31. Friday’s deposit files are expected to process as usual.
We have also received reports from a limited number of clubs of duplicate pending charges associated with iPad down payments processed on Monday, August 24. These transactions are expected to remain pending temporarily and fall off without processing.
Monitoring will continue through Monday. Clubs with questions or concerns may contact ABC at AFTeam@abcfitness.com.
Posted Aug 28, 2026 - 13:40 CDT
Update
Update: ABC has advised us of an additional impact related to this issue. A subset of members who were charged on August 24 may have received a duplicate charge.
The delayed deposit processing affecting US clubs remains under investigation. Our teams continue to work with ABC and will provide another update as more information becomes available.
Posted Aug 28, 2026 - 10:46 CDT
Investigating
We are currently investigating an issue with ABC affecting all US clubs that began Wednesday. Daily deposits associated with revenue collected through ClubOS and down payments processed through the ClubHub App have been delayed since that time.
Our teams are actively working with ABC to restore normal deposit processing. We will provide another update as more information becomes available.
Posted Aug 28, 2026 - 09:07 CDT
This incident affects: Partners (ABC Fitness Solutions).