We have completed monitoring of the Online Signup experience and confirmed that the issue affecting page progression after billing information is submitted has been resolved.
Users are able to proceed to the confirmation page after submitting billing information, and signups are processing successfully.
No further impact has been observed. If you experience any additional issues, please use your standard support channels for assistance.
Posted Jun 01, 2026 - 17:00 CDT
Monitoring
We have identified and corrected the page behavior affecting some Online Signup experiences after billing information is submitted.
Users are now able to proceed to the confirmation page after submitting billing information, and signups continue to be processed successfully.
We are monitoring the signup experience to confirm it remains stable and will provide another update once monitoring is complete.
Posted Jun 01, 2026 - 14:37 CDT
Investigating
We are currently investigating a sporadic issue affecting the signup experience after billing information is submitted.
After billing information is entered, the page may continue loading instead of advancing to the confirmation page.
Signups are still being processed successfully. We are working to correct the page behavior and will provide updates as more information becomes available.
Posted Jun 01, 2026 - 10:37 CDT
This incident affected: Technology (Online Signup).