Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 09, 2025 - 11:00 CST
Scheduled
What’s Happening: We are deploying Firmware v80 as part of the staged rollout of this access control upgrade. The update improves communication reliability between access control devices and controllers, enhances system stability, and reduces previously observed error conditions. Deployment for each phase will occur over a rolling 72-hour window.
When: Minnesota Clubs Only Begins: December 9, 2025 at 11:00 AM CT Rolling Window: 72 hours from start time
All Remaining Domestic and International Clubs Begins: December 15, 2025 at 11:00 AM CT Rolling Window: 72 hours from start time
Impact: Devices may update at different times within the 72-hour window. No extended downtime is expected. Clubs can continue operating normally throughout the maintenance period.
What You Need to Do: No action is required. Devices will update automatically. Our teams will monitor performance and device health throughout each 72-hour deployment window.
If issues persist after the update please report them through your standard support channel.
Posted Dec 08, 2025 - 10:56 CST
This scheduled maintenance affected: Technology (Access Pass).