Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 16, 2026 - 13:25 CDT
Scheduled
We’re pleased to share that ClubOS deployed a hotfix earlier this week that delivers a meaningful improvement to system performance.
Franchisees should experience significantly faster inventory refresh times, now completing in under a minute. This improvement helps streamline the process of assigning personal training sessions and coordinating schedules by minimizing delays and providing more real-time visibility into availability.
This enhancement is designed to help your teams work more efficiently with clients, with less waiting and fewer interruptions during scheduling, and ensures your teams have quicker access to accurate, up-to-date information to support daily operations.
Posted Apr 16, 2026 - 13:21 CDT
This scheduled maintenance affected: Partners (Club OS).