Our team aligned with the carriers on a proposed solution covering how the privacy policy, terms of use, and Marketing SMS disclosures are presented. As we moved through the process, one of the carriers shifted its position and is now requiring separate affirmative consent for both transactional and marketing SMS messages. We are actively working to ensure the legal basis for that transactional SMS requirement, as our goal is to minimize friction during lead capture while also scaling SMS opt-in capabilities across the domestic system.
An internal cross-functional team that includes Legal, Brand/Conversion, and Operations is aligned on the issue and actively working toward a solution. The team plans to resubmit an updated approach asap.
We understand the impact this has on clubs that rely on SMS as a key communication channel, and we appreciate your patience while we work through the carrier requirements and approval process. We will continue to share updates as additional information becomes available.
Posted Aug 04, 2026 - 11:27 CDT
Update
The Purpose Brands team is awaiting final confirmation from Twilio, the service that supports SMS messaging through Club OS.
We will provide another update once additional information is available.
Thank you for your continued patience.
Posted Jul 09, 2026 - 10:06 CDT
Monitoring
The updated SMS opt-in language is now live on all Anytime Fitness website lead forms across the United States as of June 15, 2026.
Our team has submitted the updated solution to Twilio, the messaging platform used by Club OS, for review and confirmation. We expect this process to take at least 1–2 more weeks and are actively working to expedite where possible. We'll provide an update if anything changes.
Once confirmed, SMS texting will be restored for impacted locations. No action should be needed from clubs once restored.